1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Please Help!

Discussion in 'Boss Plows Discussion' started by 06HD BOSS, Dec 19, 2009.

  1. 06HD BOSS

    06HD BOSS 2000 Club Member
    Messages: 2,611

    Snows coming and i went to hook up my plow and when i hit the button to raise the tower it sparked at the plow frame and now wont do anything. The solenoid clicks but the tower wont raise or lower. Please help asap!
     
  2. 06HD BOSS

    06HD BOSS 2000 Club Member
    Messages: 2,611

    I got the plow on by manually lifting the tower. The plow operates fine once on but the switch still doesnt do anything. It makes the solenoid click but doesnt run the pump.
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The ground lead on your power cable has a poor connection, that's why it won't power on and why you're seeing sparks at the mount when it's near the plow. The motor is attempting to ground THROUGH the mount and plow since there isn't enough ground through the power cable.

    Clean the plow side ground connection at the motor as well as the bumper connector itself.
     
    Last edited: Dec 19, 2009
  4. tuney443

    tuney443 PlowSite.com Addict
    Messages: 1,847

    Well I guess you partially answered my question B+B in the PM I shot you.That Frankenstein arc last night in the dark was pretty cool though even if it scared me some.Is there anything you don't know?:salute::D You don't have to answer that but I know you will.
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Was hoping you'd see this thread until the PM got back to you. :nod:

    Yes there's certainly plenty of things I do not know but I make an attempt to learn something new each and every single day, as many here do (thats why we're here isn't it?). And by doing so, once enough days go by you gain quite a vast knowledge in select fields if you so choose.

    You learn far more with your ears and eyes open than your mouth. :D
     
  6. 06HD BOSS

    06HD BOSS 2000 Club Member
    Messages: 2,611

    Thanks B&B. All connections are clean, nearly spotless and tight. I also checked the entire lengths of all ground wires and all are in perfect condition. Switch still does not power the pump but it makes the solenoid click under the hood. :confused:
     
  7. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Pop pump the cover off and place a test light in the back of the connector on the white/black wire at the switch and flip the toggle (in float of course). If it has power there then the switch is fine.

    The while/black runs back through the bumper plug and up to the under hood solenoid to activate it. If no power is leaving the switch on the white/black then the pump won't run.

    However, if you do not have power there then the switch is dying.
     
  8. RichG53

    RichG53 PlowSite.com Addict
    Messages: 1,135

    Dying??? I think it's already dead ...