1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

please help with lights

Discussion in 'Meyer / Diamond Products Discussion' started by nathan11507, Jan 4, 2011.

  1. nathan11507

    nathan11507 Member
    Messages: 68

    I have a meyers c-8 with e-60 when i got it the previous owner butcherd the hell out of the light harness so we hard wired with a toggle switch so i could turn them on and off when wanted. Well now they dont work and i was told i should really use a relay 40 amp to be exact. Well i bought everything i need to do the job followed the instructions got no lights at all and the relay just buzzes like mad. Any help would be greatly appreciated plse cause we got snow coming friday. I am ready to pull my freaking hair out i cant understand what im doing wrong or where the problem is
  2. maverjohn

    maverjohn Senior Member
    Messages: 902

    Sounds like the ground wire.
  3. Bashby

    Bashby Senior Member
    Messages: 228

    The buzzing is the relay kicking on ond off real fast, if you've got it wired right then you probably have a bad connection or switch, the voltage is there to close the relay contacts, but as soon as the circuit is complete the voltage drops and the contacts open in rapid succession, causing the buzz. Here's a link about headlight relay installation that may help if your directions arent so good. http://www.ford-trucks.com/article/idx/8/039/article/Whiter_Whites_Brighter_Brights.html I put 4 relays (2 for truck, 2 for plow) in mine and rewired the whole thing.