1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

PITA oil pump 92 f150

Discussion in 'Ford Trucks' started by welj31, Mar 4, 2009.

  1. welj31

    welj31 Member
    Messages: 58

    Oil pump went out on 92 f150.Called shop they say 6 hours labor:dizzy:. Just how big of a pita is this thing?:realmad: Manual say you need to pull intake pen???:cry: I think i can pull the engine in less time than 6 hours.
     
  2. tim096

    tim096 Senior Member
    from wny
    Messages: 100

    What motor is in it? 5.0 or 5.8 you have to drop the oil pan and it is a pita. 6 hours is fair. Are you shure the motor is ok? A lot of times if the oil pump is bad so is the engine. Did you ck the oil psi with a gauge? Mabe it is just a sending unit or bad wire. Hope this helps
     
  3. welj31

    welj31 Member
    Messages: 58

    its a 5.8 we installed a new sending unit and still nothing. Motor sounds ok but i have not ran it more than a 90 sec after pressure failed. I guess I should install a manual gauge just in case factoy gauge has failed. Factory unit has been reading low to med press for months now ... just figered it was a bad sending unit.
     
  4. Dustball

    Dustball Senior Member
    Messages: 274

    Never trust the factory gauges.

    It is a big job to get the oil pan out due to the engine crossmember. Upper intake comes off so you can raise the engine high enough to clear the crossmember.
     
  5. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    you do not have an oil pressure gauge. you have an oil pressure switch that activates the gauge. it is either oil pressure on not, the same as an idiot light.
    the only way to know what the pressure is is to put an aftermarket gauge and sending unit in there.
     
  6. welj31

    welj31 Member
    Messages: 58

    Well checked and still no oil pressure... Now this is scary jacked it up and found underside of truck covered in oil (still trying to find where its coming from) pulled drain plug and got about 1/2 quart of thick sluge. I had just checked oil a week before this and it was fine ....was not due for a change for another 500 miles. Oil seems to be coming from front of engine,but front of oil pan is dry. Must be spraying from somewhere?
     
  7. tjctransport

    tjctransport PlowSite.com Addict
    Messages: 1,390

    check your oil filter. it could be either plugged, missing the gasket, or have a hole in it.
     
  8. welj31

    welj31 Member
    Messages: 58

    Its comming from the front seal ...getting on the balancer and going everywhere. Must have ran out on road and cooked the rest. Hope motor is ok. guess we will see in a day or two....waiting on headers and exhaust parts to fix ones i had to torch off.