1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Parking Light Problems

Discussion in 'Boss Plows Discussion' started by DStrabb, Jan 31, 2012.

  1. DStrabb

    DStrabb Member
    from MI
    Messages: 36

    On my SH2 V the parking light and blinker stay on all the time on the drivers side and I have no parking light on the passenger side but the blinker works as its supposed to. The blinker does blink on the drivers side when turned on. This was a new install on this truck this summer its an 04 2500hd. Thanks for the help.
     
  2. DStrabb

    DStrabb Member
    from MI
    Messages: 36

    Any ideas?
     
  3. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    Have you had this problem since the install was done or did it just start?
     
  4. DStrabb

    DStrabb Member
    from MI
    Messages: 36

    From the get go.
     
  5. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    I would take it back to the installer and tell em you want it right.
    Sounds like they may have crossed wires or are using wrong or miss-connected light adapters.
     
  6. DStrabb

    DStrabb Member
    from MI
    Messages: 36

    I did the install. Was just hoping some one had an idea on what to look at first.
     
  7. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    Well that is where I would start then. Get your install papers out and start at the back of the headlights and turn signal connections. Compare left side to the right side to see if something there is amiss. As always make sure all your ground points are in fact grounded.
     
  8. bossman34

    bossman34 Member
    Messages: 67

    You didnt say if the problem goes away when you unhook the plow, I am asuming it does. My guess is that you hooked into the ground wire on the drivers side. I would say for sure you need to clip your wiring for the turn and tail and start over. I bet you will find your problem. Dont forget that it is possible for a duel element light bulb to be bad and shorting also- I have seen stranger things
     
  9. DStrabb

    DStrabb Member
    from MI
    Messages: 36

    You are right it is only on the plow truck is fine. Thanks for the tip.