1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

p0148, p0234

Discussion in 'Ram Trucks' started by cmo18, Nov 24, 2013.

  1. cmo18

    cmo18 Senior Member
    Messages: 815

    For last couple of month my truck would bog bad when I would come on to it over 2100 rpms. It would normally throw a check engine light with p0148,p0234 codes.

    I tried cleaning out the Map sensor but today hauling my small boat back on the highway it was really bad. Any time I would come on to the throttle it would act as if it was stalling out, you could hear the turbo chug for hair. It wouldnt rev over 1300 rpms.


    Could this be a bad map sensor or fuel problems? Turbo gauge reads good but no throttle and no black smoke.
     
  2. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    148. Is fuel delivery. 234 is over boost . What year truck? Is it modified? You need to give ALL details.
     
  3. cmo18

    cmo18 Senior Member
    Messages: 815

    2006, 5.9l 140,000km bone stock other than a 4" exhaust.

    Truck doesnt burn any black smoke like it use to, almost feel plugged up but after today its not getting fuel.. A few weeks ago it also threw a loss of voltage code to pcm...which all direct to map???
     
  4. snowpro44

    snowpro44 Member
    Messages: 45

    sounds like a fuel pump or fuel problem
     
  5. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    Loss of voltage, check ALL grounds and clean and check batt connections. Also check batt condition with a good meter and someone who knows how to use it. If it's down on amps vs advertised get 2 new ones. Electrical condition is very important on these trucks. Do a volume and pressure test on fuel pump. These trucks will run without a working lift pump, but at a lower power level.
     
  6. cmo18

    cmo18 Senior Member
    Messages: 815

    I cleaned the map sensor a day ago, then it got worst. Today i put some di electric grease on the plug and it driveable but still acts up...
     
  7. jhenderson9196

    jhenderson9196 Senior Member
    Messages: 615

    The over boost code will put you in limp mode. Clear the codes first.