1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

One month old Whelen Mini Edge strobe out ?

Discussion in 'Strobe Lighting' started by Snowaway, Feb 26, 2009.

  1. Snowaway

    Snowaway Senior Member
    Messages: 248

    I just noticed that one of my strobes is out. I peaked threw the the lens and I could see the element fairly well. The element looked ok. This light bar is only one month old.
    Does any one have any ideas as to where I should start?
  2. groundbreakers

    groundbreakers Senior Member
    Messages: 824

  3. Pirsch

    Pirsch Senior Member
    Messages: 596

    Check your grounds, your fuses. If you switch it on do you hear it powering up for discharge? If not your not getting power to the strobe module. If it's just a single bulb out, since it's so new take it back to where you got it. You may just have a bulb out but it may be something else. You should have a warrentee on the thing.

    Good luck to you.
  4. Snowaway

    Snowaway Senior Member
    Messages: 248

    I would love to take it back, but I bought it from sirennet and there is no dealer were I live. I think I would have to fly it to Whelen for repair, plus it's snowing. So I think it would be best to try to fix it myself, and just fly the parts here. I believe It is the 9mm. Only the passenger side rear stobe is not working. All of the strobes are wired to the same switch.

  5. fordzilla1155

    fordzilla1155 Senior Member
    Messages: 127

    A good lesson to buy local and from someone that will stand behind you...
  6. murphyslaw

    murphyslaw Senior Member
    Messages: 443

    have you tryed contacting sirennet? If not then dont count them out. They have exchanged stuff for me before.

    I buy from sirennet before local for the fact all the shops here are dicks, and charge about 20% more after the cost of shipping.

    plus I used to work for sirennet when I lived in Or.
  7. massfirefighter

    massfirefighter Senior Member
    from mass.
    Messages: 128

    I'd swap out a working head with the bad first to confirm that the tube is bad.
  8. stroker79

    stroker79 2000 Club Member
    Messages: 2,802

    Im sure sirennet will take care of your issues. They are great people to work with and I never have had any issues with them.
  9. kitn1mcc

    kitn1mcc Senior Member
    Messages: 516

    un bolt the bar and send it to chester

    or open the bar up and take out the bad strobe and send it to chester
  10. Fourbycb

    Fourbycb Senior Member
    Messages: 574

    Pull the cover off and check the wires that supply that lighthead I know strobe do get warm and maybe it made a loose conncetion check wire and wiggle around before sending off I too have purchased alot of lights from Sirennet and have not had any problems and they will work with you as they are a hugh Whelen Dealer