1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Old unimount

Discussion in 'Truck & Equipment Repair' started by Stang69, Aug 17, 2014.

  1. Stang69

    Stang69 Junior Member
    Messages: 5

    This plow was installed on my f 250 in late 98. The truck is a 99ld 1 owner with 65,300 actual miles, it was owned by a school district. It's definitely not my first choice for a push truck but it runs and handles like new, no serious rust under neath, and it came with the 7. 6 pro plow and a tommy lift that work nice.

    Anyway....after I mounted the plow I thought I did something wrong because of the excess gap between the truck and the lift mech. And also I'm only getting about 8.5-9 inches of ground clearance when blade is up. The pump sounds like new and doesn't struggle at all to lift or angle. Do you guys think this is a common issue with this truck/mount combo?

    I'll try to post a couple pics if I can. Thanks for your time.....

    image.jpg
     
  2. Stang69

    Stang69 Junior Member
    Messages: 5

    Here's another...sorry for low quality pics...

    image.jpg
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Well the gap can be decieving on different trks. What you need to worry about is the angle of the headgear which picks up your plow. It looks like its leaning foward yo much
     
  4. Stang69

    Stang69 Junior Member
    Messages: 5

    Yes...that's what I meant . Too much forward tilt, but I can't see where anything is bent, truck side is solid and flush. The mount was installed by an equipment co. Many years ago.

    Will this damage the pump in any way? Or are you just sayin I'm gonna be running over a lot of stuff during transport?
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    OK. Look at the truck side mount. It should be straight not angled any which way. If thats OK. Then the tower brackets might be to long. I thought I read that there are 2 different ones. Might look into that as well
     
  6. Stang69

    Stang69 Junior Member
    Messages: 5

    Oh man....I don't know how I overlooked it but the trk mount is actually tweeked a little bit. What a goof! No more drinking in the garage I guess...thanks for your time though.
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,983

    Tweeked as in how?