1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Old Monarch Dynamatrics Snow Plow Pump

Discussion in 'Truck & Equipment Repair' started by half finger, Oct 9, 2011.

  1. half finger

    half finger Junior Member
    Messages: 2

    I can sure use some help. I have looked up all the sites I could find on Monarch(Butcher) yet I have not been able to find the proper connection sequence. It has a Prestolite motor and all looks original and was said to work properly. My controls show - raise yellow, blue lower, red and green to angle. It also has brown and black wires indicating they go to a solenoid? The pump has out the top a red,blue,yellow(orange?), green with a bluish green wire coming from the base of where the other wires go out the top. I cannot get the motor to turn yet it sounds likeit is trying to get current. I just don't think I have the wires properly attached. Thanks for any help.
     
  2. jrod8124

    jrod8124 Junior Member
    Messages: 11

    thick red is power thick black is ground brown is solenoid red and green are angle yellow and blue raise and lower. hook power on thick red and then ground on thick black. hook up secondary power on brown and motor should turn over then go from there.
     
  3. half finger

    half finger Junior Member
    Messages: 2

    Monarch snow plow pump wiring

    Thanks so much. I am still curious as to where the bluish green lead that comes from the base of the pump goes. The red,yellow,blue,and green come out from the top and this wire comes from the lower part of the exit plug? Thanks
     
  4. jrod8124

    jrod8124 Junior Member
    Messages: 11

    most liikely it is for down pressure