1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Ok i need help with my Fisher Any takers???

Discussion in 'Residential Snow Removal' started by Nascar Fan, Dec 17, 2003.

  1. Nascar Fan

    Nascar Fan Senior Member
    Messages: 167

    Ok here it goes.I have a Fisher MM Sehp setup and any info would be appreciated.I have a problem with the plow raising and dropping very slowly.Now i replaced the truck battery and it still not right.When i hit the lower on the control, the plow goes down but not very fast,at all and it's like the full weight of the plow isn't on the ground.if i start at the bottom of a hill,and i get to the top,i have to stop, let the plow continue to lower or it will not plow when the truck levels out.Now when i raise it up,it always comes up but slowly,side to side is fine.I hit the lower on the control and counted 0ne thousand one,onethousand two, ect ect... i was @one thousand 7 before it was on the ground.ANY ideas?Yes the plow had been being used so it was warm but it does not matter as it makes no difference at all hot or cold as to it's speed.I even tried pullimg the "quill" all the way out of the top per Fisher's adjustment and it made no real difference.PLEASE People i have been fighting this stupid problem for a while.I also forgot to mention i replaced the lift ram packins and nuy and it's just over hand tight.
    Last edited: Dec 17, 2003
  2. Nascar Fan

    Nascar Fan Senior Member
    Messages: 167

  3. Mdirrigation

    Mdirrigation Senior Member
    Messages: 408

    Sounds like it could be a restriction in a hose . I am not familar with fisher but if I remember its a under hood pump. If so and you say the side to side is fine , try taking a side hose off and swapping it with the up and down hose. if it works it is a flow problem replace the hose . Also check for obstructions in the fittings at the pump and piston
  4. ford250LDMaster

    ford250LDMaster Member
    Messages: 62

    you should change your fluid every year.are you using fisher hydro oil i hope??? ATF is not real good for those pumps.the oil gets thick.the key is to have very thin hydro oil like western and fisher make for there plows.your valve might not be opening all the way also.it might be gummed up with crap
  5. Nascar Fan

    Nascar Fan Senior Member
    Messages: 167


    I have replaced the fluid with new ATF because thats what the sticker says to use.NOw while i was at the parts store i noticed they sell some blue fluid,made by some snowplow aftermarket company.I grabbed the bottle and noticed immediatly it sounded like water in it.It was that thin.The label says it was safe for ALL plows and good for -35 or -50 but it was good for way more than we usually get.Should i try that stuff?Just sounds real, real, thin for it.Thanks Tom
  6. ford250LDMaster

    ford250LDMaster Member
    Messages: 62

    what pump model is it does it have a filter inside
  7. Nascar Fan

    Nascar Fan Senior Member
    Messages: 167

    Pump model?

    All i can tell you it's a Fisher electric/hydraulic with the pump in the bottom of the housing that the electric motor sits on top of. The lift ram and pump are all intregated together with the control coils on the back of the housing.It's a M/M setup if that helps.Yes it does have a filter on the pump unit itsel and it is clean.
  8. ford250LDMaster

    ford250LDMaster Member
    Messages: 62

    do you have a remote to control it or a cable.sounds like a valve problem to me
  9. Rappa

    Rappa Member
    Messages: 84

    Pull the pump apart and change the filter. Use the Fisher oil. Thats where i would start. Actually had the same problems this winter with an older Fisher setup we have at the shop. That worked. But id that doesnt work, you may want to check for restrictions in your hoses.
  10. Nascar Fan

    Nascar Fan Senior Member
    Messages: 167

    I FIGURED IT OUT !!!!!!!!

    It was just an adjustment.I feel like an idiot beating my head against the wall so long for a stupid 5 second adjustment.At least i figured it out in the garage instead of paying money for someone else to call me a moron...... :bluebounc Thanks for all the help everyone!!!I really appreciate it!!!!!!
  11. wirenut

    wirenut Senior Member
    from nh
    Messages: 507

    what was adjustment fix....you said you pull the quill out. i thought that was the adjustment
  12. ppkgmsy

    ppkgmsy Member
    from Vermont
    Messages: 73

    Glad you got it figured out. Wish I had a nickel for every time it took me too long to find a simple fix.
  13. justme-

    justme- 2000 Club Member
    Messages: 2,138

    WOW , talk about post hunting!!!! 2003!!!