1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Nothing Work

Discussion in 'Meyer / Diamond Products Discussion' started by KartAnimal29, Jan 20, 2011.

  1. KartAnimal29

    KartAnimal29 PlowSite.com Addict
    from Ct.
    Messages: 1,482

    As I was plowing the other night and everything stopped working. When I touch a button on the remote , it just goes dead. plow will not angel or raise or lower. E-57 pump if that matters
    Last edited: Jan 20, 2011
  2. bdschumaker

    bdschumaker Junior Member
    from IL
    Messages: 13

    Check and clean all electric connections. Especially the power and ground from truck to pump.
  3. fordsuvparts

    fordsuvparts Senior Member
    Messages: 134

    If you have the mdII style electrical connector, pull it part and check it for corrosion, they are very bad for this happening. Check and clean all connections means actually remove the wire and clean the end of it and where it attaches to your truck or the pump with a wire brush and then I always use dielectric grease on every connection. Let us know how it goes.
  4. KartAnimal29

    KartAnimal29 PlowSite.com Addict
    from Ct.
    Messages: 1,482

    Your going to laugh at this one. I was taking the plow off this afternoon to head to the bank and noticed that the 4 way plug at the frame was undone. Man do I feel stupid LOL I put a zip tie around it to make sure that doesn't happen again