1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Noisy slow pump

Discussion in 'Western Plows Discussion' started by Elite Property Services, Jan 11, 2010.

  1. Elite Property Services

    Elite Property Services Senior Member
    Messages: 230

    I have a 8' unimount isarmatic last year this happened to me and I don't remember what it was fluid is fine the pump become very sluggish and loud. Any ideas?
     
  2. leeddog65

    leeddog65 Member
    Messages: 85

    MY guess, in this weather, is that you have a little bit of water in the system and its freezing. Used a friends plow a few years ago, did the same thing when it get below 0 windchill. Either drain the fluid or add a cap full of HEET.
     
  3. Elite Property Services

    Elite Property Services Senior Member
    Messages: 230

    I put some heat on it it and seams to work fine now so you might be right I will drain the fluid and then put a cap full of heet in and see if that helps. Thanks alot.
     
  4. twinman326

    twinman326 PlowSite.com Addict
    Messages: 1,683

    Before you add fluid, I would recommend cleaning the system completely, and the filter.. I use brake cleaner to clean the inside of the housing and the filter. Then I use a air gun to blow everything out.
     
  5. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    iced up for sure.