1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

no up or angle please help

Discussion in 'Truck & Equipment Repair' started by deere06, Dec 8, 2012.

  1. deere06

    deere06 Junior Member
    from maine
    Messages: 1

    ok so i got a minute mount 1 two plug mounted on a dodge 2500. the problem is it will not raise or angle. i have changed fluid and filter checked wires from controller to the valve coils. everything seems to be ok. next thing is i just replaced motor it was junk. i have also pulled the three cartridge valves and coils they seem to be good. i have cracked the hydraulic hoses to see if air bound but there is oil and it does pump. when using joystick control to see if it works the pump sounds weird like a squealing noise i have spent two solid days trying to fix this thing please help. oh it is an 8 foot straight blade
  2. ScubaSteve728

    ScubaSteve728 Senior Member
    Messages: 458

    check the plow plug connections
    clean with a wire brush and stick a toothpick in all the little holes then hit it with some electric contact cleaner and then dielectric grease and it may fix it
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,742

    Ok try this. Remove the pos cable from the underhood solenoid. Rubber band the clicker up,left,or right. Then go out and ck the coils and see what you have. Should have all gnd to all coils,,then depending upon function, you should have pwr to one or more coils..so try this and report back. Also use test light not a meter