1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No Power to the Plow

Discussion in 'Truck & Equipment Repair' started by dRam2500CT, Mar 2, 2006.

  1. dRam2500CT

    dRam2500CT Member
    from USA
    Messages: 45

    I have a Western 8' Pro Plow for my Ram 2500. Plow itself is in its second season of non-commercial use, truck is an 03 hemi. 2 weeks back when we got about 2' of snow, plow was working great.

    Now today it is going to snow about 5 inches, I hook up the plow to the truck, all the wires (3 plugs in total), and nothing happens. No lights, no power to my hand control, no nothing. Seems like there's no juice going to the plow at all.

    I'm not sure what to do now, what to check for. I am unfamiliar with plow setups and the service places down the street are closed and cannot see me till tomorrow morning. Is there anything I can check to try to solve the problem myself at home tonight? Any thoughts on the problem? I have been told maybe some sort of solenoid? Problem is I'm not 100% sure what a solenoid looks like.

    Any help is appreciated ;)
     
  2. ght1098

    ght1098 Member
    Messages: 86

    Should be a fuse in the red wire to your hand controller, start there. If that is not it the easiest thing to do would be to go to westerns website and download the service manual. Maybe someone else has some other ideas. Good luck.
     
  3. Mowerpan

    Mowerpan Senior Member
    Messages: 305

    Ok heres a very basic way the plow works. There is the hydraulic pump and is has valves, which in your case are actuated by electricity. When you push on the button for up, down, left or right, this opens the valve for whatever you pressed, and ALSO actuates the solenoid, this is turn gives the pump power and either angles, or go up. For going down, the solenoid is not actually only the up and down valve. I'm gonna say I doubht it is your solenoid, as your controller isn't even getting power, where as even if the solenoid was bad, the controller would still be getting power. First I would find the 12 volt wire that goes to the controller and confirm if there is power to it or not.(Could be your controller is faulty and this test will determine that). If there is no power going into the control, start backtracking. You will need either a test light(cheap) or a multimeter. Find where the wire that supplys power to the controler goes and follow it. I'm not super farmiliar with these systems but I'm going to go out on a limb and say the power wire for the controller attaches directly to the battery. But either way backtrap the power wire, and find out where it stops getting power from. I'm betting the wire that supplies power for your controller is not getting power.
     
  4. dRam2500CT

    dRam2500CT Member
    from USA
    Messages: 45

    Thanks Mowerpan, that makes sense that it's not a soleniod.

    I will check on the controller wire as you and ght1098 suggested. My father is out in the truck now, hopefully when he gets back I will have time to attempt to backtrack and find out if that controller wire has power. I tried going through the nest of wires for the plow under the hood earlier and didn't know where to begin.

    Other suggestions are still appreciated, looks like I may be taking a trip to my local service place tomorrow though :cry:
     
  5. justme-

    justme- 2000 Club Member
    Messages: 2,138

    1 make sure the power button on the controller is on - heard of several people simply forgetting to flip the switch on the old joysticks, not sure about hand controllers but I think there is a power button

    2 make sure the connections on the plugs are clean- were the caps off letting salt and dirt in at any time since you last plowed?

    Check all the fuses in the truck as a normal thing too.
     
  6. cm70

    cm70 Junior Member
    from NH
    Messages: 8

    I had a similar problem with my Western Pro Plow 7.5' plow which is only a year old. As others have mentioned the problem is in the controller or power to the controller. Nothing will happen if the controller won't turn on.

    In my case the red power wire that goes from the handheld controller to the fuse box had a bad connection at the fuse box. Follow the controller cable underneath the dash and you should see a separate red wire that goes to the fuse box. Also some of the western controllers have a glass fuse inside the actual handheld controller, you unscrew the plastic handle and it is inside (mine did not but the owner's manual showed a picture of the fuse, I'm guessing it is an older manual).

    You should also check under the hood by the isolation module there are a couple of fuses there that could be blown. The only thing the owner's manual says to do if the control pwoer light doesn't come on is to check the 7.5amp fuse and/or wiring.

    And if you haven't already done it, connect and reconnect all the cables to make sure you have a solid connection.
     
  7. dRam2500CT

    dRam2500CT Member
    from USA
    Messages: 45

    Hey thanks for the replies guys.

    I still have yet to have the time to look over the wires, but I did connect and disconnect the main plugs about 10 times yesterday and then had my dad try to no avail. A friend (with much electrical knowledge and truck maintenence knowledge) is going to take a look at it tomorrow, he mentioned that it is probably the fuses, and looking more into my troubleshooting guide with my snowplow info it seems to back our theory up.

    I should be able to get a good look at things tomorrow, I'm in no rush now, we didn't get that much snow, and I already took out the snowblower.

    I'll update hopefully tomorrow or Sunday to let ya all know what I've found.

    Edit - Also, the caps have been off but all of the plugs look clean. I have no power to the controller, so when I touch the power button it doesn't respond. I think under normal conditions whether I have the plow on or not, as long as the handheld controller is connected it lights up and I can hit the power button.
     
    Last edited: Mar 3, 2006
  8. dRam2500CT

    dRam2500CT Member
    from USA
    Messages: 45

    Eh, replaced some fuses today, still having some problems, got the blade moving a bit, still power is on and off to the controller. With my friend I imagine I could go through all of the wires more and replace more, but I don't want to cause more damage.

    I'm taking it to a shop that sells Western's Monday or Tuesday.

    Thanks for the help guys. Even though I didnt fix it, I did learn a bit more about the plow. :nod:
     
  9. zapster

    zapster Member
    Messages: 34

    did you ever think of checking and cleaning the BATTERY connections?

    i was doing some heavy duty plowing last yr (fisher) and somewhat of the same thing happend

    was at the end of a driveway..
    went to raise the plow..
    nothing...
    nothing at all and all was fine up till then(had been out 3 hrs)

    got the jack out and manually raised it and used the over the road chain to get back..

    went to where dad works (fisher dealer/installer)

    we checked everything..joystick..isolator box...new this and that..

    still nothing

    the battery the plow set up was drawing power from had a loose connection at the positave side
    truck has 2 batts so starting was no problem...fooled us!

    first and last time that will happen:nono:

    ...zap!
     
  10. dRam2500CT

    dRam2500CT Member
    from USA
    Messages: 45

    Alright, Solution:

    First, replaced 2 fuses and the lights started working. Then after I thought I checked EVERYTHING and nothing was loose/cut and the plow still wasn't moving, I took it to a Western Installer.

    $33 later (not bad, I expected more for labor) they tell me all that was wrong was the wire going to the fuse box for the controller was loose. I could've sworn it was in, I popped the hood specifically to check it that evening.

    Oh well, at least it wasn't something serious.