1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

no power to switch???

Discussion in 'Commercial Snow Removal' started by fga, Jan 19, 2005.

  1. fga

    fga Member
    Messages: 51

    what's up? having a small roblem, hopefully its small. the other day i randomly checked the plow functioning and it was normal. today i go out to hook it up to move the blade, and it's like the system is dead. i get no lights on the electric control panel. no clicking, nothing. if i touch the 2 screws on the solenoid, the motor operates on the plow, so i am getting power to the solenoid.. i just seem to have nothing going into the cab.
    i followed the harness from the control box under the dash. it goes out through the firewall, and one blue wire goes out on its own into the spaghetti... any help or ideas. maybe fuse, or something stupid like that?
    how could i test if the switch is good, or getting power?
    i'm starting ot panic cuz we finally have the storm coming in on sunday.
     
  2. Grshppr

    Grshppr Senior Member
    Messages: 268

    I had the same problem and it was a fuse. THere should be one before the power gets to your control panel.
     
  3. lawnboy11

    lawnboy11 Senior Member
    Messages: 263

    Hey man, good luck with the problem, but if you can't fix it at least you'll have 2-3 days b4 the storm we're hopefully getting on the wknd. Tonight should be a weak storm ,but maybe if you're doing resis you can broom or shovel. Actually, fire up a backpack blower. Works awesome in light snows when it's cold, light, and fluffy!