1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

no power issue help needed

Discussion in 'Truck & Equipment Repair' started by nista, Dec 28, 2015.

  1. nista

    nista Junior Member
    Messages: 5

    I have a fisher 3 port minute mount STRAIGHT BLADE
    JOYSTICK SOLENOID CONTROL … I have power to lights but not to control box… both fuses are fine, when I connect 2 prong vehicle battery cable, I get a click in the solenoid, the plow jumps a bit, and light on control box flickers for a second… when completely connected, nothing…. I have cleaned all connections, I have checked all fuses, unless I am missing one that might go to the control box itself, however I don't believe I would get a flash of the light if the fuse was out... please help
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,962

    What about the controller power hooked up?
     
  3. nista

    nista Junior Member
    Messages: 5

    controller is getting power if light flickers a bit, but won't power up when connection fully connected
     
  4. nista

    nista Junior Member
    Messages: 5

    here is the wiring diagram

    STRAIGHT BLADE WIRING – 3-PORT, 3-PLUG SYSTEM.jpg
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,962

    Last edited: Dec 28, 2015
  6. nista

    nista Junior Member
    Messages: 5

    I figured it out… the control main power was disconnected….

    IMG_4693.JPG
     
  7. nista

    nista Junior Member
    Messages: 5

    thank you dieselss for your input… very much appreciated!:nod:
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,962

    Copy that...