1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

NO Plow lights

Discussion in 'Western Plows Discussion' started by RNR Services, Nov 2, 2012.

  1. RNR Services

    RNR Services Junior Member
    Messages: 19

    I just hooked up the 12 pin harness to my 2003 yukon. plow came off 2004 chevy 2500. It had a broken post on 1 if the relays so I replaced it exactly how it was. when I plug it in the headlights stay on on the truck and don't switch to the plow. Fuse is fine. Any suggestions?
     
  2. Chiputz

    Chiputz Senior Member
    Messages: 165

    Go Western's website and check out the schematic. Sounds like some wiring isn't right or a bad relay. The schematics are color coded and easy to read. You can look at the vehicle specific install instructions for the harness.
     
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    You could have one of two problems. You switched the system from one vehicle to another so it is possible that the headlights are wired different on the new truck. If both vehicles have single headlights then it can be made to work but you need to verify that the pinout on the new truck is the same as the old. The other possibility is that the new relay has a different pinout than the old. That is the relay looks the same and has the same pin orientation but internally those pins go to different functions.