1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No movement

Discussion in 'SnowDogg Snow Plows' started by xmoto, Jan 16, 2011.

  1. xmoto

    xmoto Junior Member
    from NY
    Messages: 4

    I just bought a MD75 used. I was told it was a 2009. The motor runs but the plow doesn't move. It sound like it would if it was to the stops bypassing fluid. I check the three coils and pulled out the vales but no change. I am also getting the blinking lights on the controller. either 2, 3, or 4 depending on which direction I try to move it first. Help please.
     
  2. RangerDogg

    RangerDogg Senior Member
    from ma
    Messages: 201

    does it go up or down.Ifit does and doesnt go to side might be piston stukk spray wd and push on curb to move it and check all connections
     
  3. npi9181

    npi9181 Member
    Messages: 32

    where are you in NY
     
  4. xmoto

    xmoto Junior Member
    from NY
    Messages: 4

    Albany area.
     
  5. xmoto

    xmoto Junior Member
    from NY
    Messages: 4

    Update, I got the plow working. The lift and one of the angle cylinders were stuck. It works normally now but I am still getting the blinking lights in the controller, either 2, 3, or 4 depending on which direction I move it first. :dizzy:
     
  6. stotts1

    stotts1 Member
    Messages: 42

    mine threw the same codes, at first it bothered me:realmad: until i found out that buyers put out a tech bulletin about this. here is the link
    http://www.snowdoggplows.com/Technical Service Bulletins/16-TSB28.pdf
     
  7. xmoto

    xmoto Junior Member
    from NY
    Messages: 4