1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No low beams on ultra mount but everything else works.

Discussion in 'Western Plows Discussion' started by lawnboy647, Oct 15, 2013.

  1. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    I have a 2013 2500hd that i just installed my 8' straight blade ultra mount on.
    Everything works but the low beams, and i know its not the plow because they work on the other truck. Also the plow for the other truck has no low beams when installed on mine. I have a 3 port 3 plug set up and everything appears to be in excellent shape. Truck headlights go off but plow low beams do not come on. Any help is appreciated thanks!!
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,663

    Look in manual how to determine if it is negative or postive common for the headlights.
     
  3. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    Checked that and they said that does not apply for 2013 Chevy.
     
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,663

    Can also try flipping the head light connectors and make sure you are using same side on both connectors.
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    What truck did the plow come off of?
     
  6. Western1

    Western1 Senior Member
    from MI.
    Messages: 678

    Yes try flipping connectors and make sure they are the same from side to side.
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,971

    Yep. Flip from A to B
     
  8. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    Thanks guys I will try flipping tonight and let you know.
     
  9. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    Just checked and all my connections on truck headlights are ad should be. So any other thoughts?
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,971

    Did you try and flip the connectors just for grins?
     
  11. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,663

    Did you try flipping the connectors? I am at a loss if that does not correct the issue.
     
  12. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    Are we talking the headlight connectors on the truck side? If so then there is only one way they can go in as they have grooves in them.
     
  13. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    They're talking about moving the wire locations in the plug itself. Some vehicles use power to the light for control some control it with the ground. you have to move the wiring to match your vehicle. Now we know you have a 2013 Chevy, what truck did the harness come off of?

    Pay attention to post #9 and Post #15 in this thread it will explain what they are telling you.:waving:
     
  14. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,663

    The connectors for the truck's headlights connectors that plug into your plow harness. The plow harness side is reversible.

    plow 001.jpg

    plow 002.jpg
     
  15. lawnboy647

    lawnboy647 Junior Member
    Messages: 11

    U guys were right th a and b just needed to be flipped! I was just thinking so hard that i looked right over the fact that there was the other set of connections!! Thanks for all your help and patience!!!!
     
  16. Western1

    Western1 Senior Member
    from MI.
    Messages: 678

    Let it snow!!!