1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No Highbeams

Discussion in 'Ram Trucks' started by fury0us, Jan 3, 2016.

  1. fury0us

    fury0us Junior Member
    Messages: 14

    I have a 2002 dodge ram with a boss 8'2 v plow with and 11 pin harness. I have no high beams on the truck or the plow. I have the adapters and relay set up for my truck. The lowbeams work fine when I switch to high beams nothing. I unplugged all the plow harness and put everything back stock and the ones on the truck work as normal. I took all the connections apart and cleaned and regreased them. Any one have any Idea's? Bad relay maybe?
    Thanks,
    Chris
     
  2. fury0us

    fury0us Junior Member
    Messages: 14

    nobody has had this problem?
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 11,005

    Try the boss fourm.
     
  4. cl733

    cl733 Senior Member
    from Canada
    Messages: 252

    DRL module possibly
     
  5. maxwellp

    maxwellp PlowSite.com Addict
    Messages: 1,112

    Did they ever work? If yes - could be a relay.
    If it is a new install and does not work there is a wiring problem.
     
  6. cl733

    cl733 Senior Member
    from Canada
    Messages: 252

    I had an 02 and had nothing but problems with the head light switch
     
  7. allen81

    allen81 Member
    Messages: 97

    I have a similar issue but I have a fisher on a 99 dodge ram 2500 ps light comes on plow high beam only if I switch to low beam I have no plow lights