1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

no heat

Discussion in 'Ram Trucks' started by beam, Jan 3, 2010.

  1. beam

    beam Senior Member
    from pa
    Messages: 314

    I have a 2006 2500 quad cab with the 5.9 cummings and yesterday every thing was fine had heat in the cab stopped for a coffee came out left the truck running and no heat it was blowing cold air and the guage said about 160 so started going and put the pedal to the floor and the temp guage went up to 200 and still no heat then went all the way up to 245 on the dash i slowed and it went back to around 200 stayed around that temp for about 5 min and all of a sudden I had heat the rest of the night any ideas on what the problem might be????
     
  2. poncho62

    poncho62 Senior Member
    Messages: 431

    Blockage in the heater hose....I would have shut it off before it hit 245........Think about getting a flush...and a new thermostat
     
  3. Green Grass

    Green Grass PlowSite Fanatic
    Messages: 9,573

    Is the truck low on coolant? Those trucks are known for a heater hose on the passenger side of the engine for leaking. When the truck gets low on coolant the first spot that does not get coolant is the heater core.