1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No gauges, no bus

Discussion in 'Ram Trucks' started by Red_Rattler, Nov 28, 2004.

  1. Red_Rattler

    Red_Rattler Senior Member
    Messages: 201

    Once again my truck has no gauges, we have tried cleaning the connections on the back of the cluster, no dice, checked all the grounds, no dice, got new cluster, no dice, finally broke down and spent 700 bucks for a new compter... the one on the firewall. that worked for 3 days, now its back to the same thing. Check engine light comes on and says no bus in the odometer. I'm at my ends wit with this truck since i just recently bought it, i have only driven it 250 miles in 2 months because of this prob. BTW the truck is a 2000 3/4 diesel. Any ideas would be much appreciated. :help: :cry:
     
  2. Tarkus

    Tarkus PlowSite.com Addict
    Messages: 1,113

    When you replace the computer it worked for 3 days correct? If so it sounds like something is pulling down or overloading the ECU output to the gauge and causing the failure. Ohm check all circuits related to it and look for a bad ground somewhere else on another circuit that is trying to ground though gauge circuit.
     
  3. bmh1202

    bmh1202 Junior Member
    Messages: 28

    Had the same problem with my 2000 1500. Took it to the dealer and was charged $150 to be told they couldn't find anything wrong. Offered to replace the cluster for $700. Haven't had problem for about 2 months.