1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No clue why? Help please

Discussion in 'Commercial Snow Removal' started by Clapper&Company, Feb 24, 2005.

  1. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Ok guys I need help with this one. I'm so lost it isnt funny..

    I was plowing a drive way, when I went to raise the plow, it didn't raise, or angle. I start troble shooting, the motors runnig and every thing.
    If I unhook the right Hose, it will raise and angle left with no problem. When I hook it back up, it will angle both ways fine as along as the plows raised, if you lower it, were back to nothing.

    I'm lost on this on guys, i dont know why it would do this. If you have any ideas please help. Or give me a map so i'm not lost.
  2. LI landscaping

    LI landscaping Junior Member
    from NY
    Messages: 21

    what brand plow?
  3. Robhollar

    Robhollar Senior Member
    Messages: 766

  4. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    Its a myers 7.5' E-64

    think I might be sucking air.
  5. Bolts Indus.

    Bolts Indus. PlowSite.com Addict
    Messages: 1,176

    Most often when functions are eratic, you know one minute this won't work and then the next minute it does but something else won't work then it is usually the main electrical plug that is loose. When you raise it, it puts the plug tighter or looser. Usually because truck side plug is rigid to the truck. For this reason especially on the Blizzards because the main harness is so stiff I recommend a little wiggle room on truck side.
  6. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    Check all of you electrical connections. I would be willing to bet you lost ground somewhere along the way, and with the plow in the up position it is making contact.
  7. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    ok i'll check them..

    The hose, is leaking round the swivel, I took it off and blowed air though the lin, it was leaking ( I could feel air) Do you think it could be sucking air, causing it to hydo lock, or something??