1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

"no bus"

Discussion in 'Ram Trucks' started by LwnmwrMan22, Mar 16, 2005.

  1. LwnmwrMan22

    LwnmwrMan22 PlowSite Fanatic
    Messages: 27,864

    This started happening this year on a 2003 Dodge 2500, HO Diesel, 4x4.

    When I'm doing a sidewalk, and the truck idles for a period of 5-10 minutes, I come back in the truck and all the lights on the dash are lit up, ie tranny light, fuel light, seat belt, brake, etc etc.

    All the gauges have quit working.

    Where the mileage is displayed, it says "no bus".

    The windshield wipers work if they were on, but I can't shut them off, or if they were off, I can't turn them on other than turning the switch and waiting for what "seems" to be a relay to reset.

    If my high beams are on, they'll switch to low beam and back again to high beam about every 1-2 minutes, the same time I'll regain control of the high beams for a moment.

    Any ideas anyone????
  2. festerw

    festerw Senior Member
    Messages: 986

    Usually means a bad connection between the computer and the guage cluster. So if you feel like an adventure you could tear it apart and look or for an even bigger adventure head off to the dealer's service department.
  3. justme-

    justme- 2000 Club Member
    Messages: 2,138

    Definatly the CCD bus area. Just checked my shelves but no 03 Ram diag manuals.