1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

No bright lights

Discussion in 'Boss Plows Discussion' started by rblake, Dec 5, 2010.

  1. rblake

    rblake Senior Member
    from dayton
    Messages: 291

    Went out to check some lots this evening and my bright lights are not working on the truck or the plow. Could it be the relays. The plow is a 9.2 v blade rt2 2000. Any ideas?
     
  2. elecblu

    elecblu Member
    Messages: 79

    Do the brights on the truck work with the plow unhooked? If so , swap the relays from one place to another. I am also assuming this is not a recently installed unit and was working proper last season?
     
  3. yardsmith

    yardsmith Senior Member
    Messages: 248

    I had similar prob on my RT2-
    my headlight had popped off right where the pedestal was spot welded & mounts into the tower. I welded it back together, but only after using a test light did we find that the connection wasn't enuf. So i had to drill a hole in the bezel & re-ground the wire that grounds the light bulb. hope this helps
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Shouldn't be any relays on an RT2. What make and model of truck?
     
  5. REAPER

    REAPER 2000 Club Member
    from 60050
    Messages: 2,228

    I had this problem with my RT3 last year. Also the right turn signal/parking light would not work. Turned out to be broke pins in the 11 pin connector. I replaced the plow side wiring and everything worked again.