1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Newby here. Unimount w/pro always twitches right first?

Discussion in 'Western Plows Discussion' started by Blackpearl#1, Sep 26, 2013.

  1. Blackpearl#1

    Blackpearl#1 Junior Member
    Messages: 14

    New to this forum but not the world of forums or westerns. Long story short is when up or left on controller is pushed (joystick type). I get a little right first. Last year while hunting down another issue I tested all 3 solenoids and they all tested fine. Just guessing someone else here has run into this and has a quick answer. Any feedback is greatly appreciated guys. As for my username, my first Harley was Black pearl and also was my first forum user name. I have already learned lots here and thanks to the regulars who are always happy to share their knowledge. Ya know they say experience is something ya gain a minute after ya needed it!!.
    Kris
     
  2. nealybird

    nealybird Senior Member
    Messages: 714

    Hi Kris! welcome to the forum. that's a cool username, mine also comes from an old nickname/username I've used forever.
    I don't know the answer to your problem right off hand. someone else will have it for you, I expect. meanwhile I'll see if I can figure it out too. .. and yea, it wouldn't be a bad coil.
     
  3. Blackpearl#1

    Blackpearl#1 Junior Member
    Messages: 14

    Thanks for the welcome and reply. I will hang in there. As bad as I want snow, I think I am safe for a while yet.
    Kris
     
  4. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,290

    I have had 2 things cause this 1 was a bad joy stick the other was corrosion at tje female side 9 pin connection a bad valve would be all the time
    P.S I've been on vacation in black River Falls awesome place 2 live
     
  5. Blackpearl#1

    Blackpearl#1 Junior Member
    Messages: 14

    OK I will try both of those, and yes I live in the middle of bumble fluff nowhere and would have it no other way. Thanks for the recommendations.
    Kris
     
  6. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,290

    Let us know what you find
     
  7. Blackpearl#1

    Blackpearl#1 Junior Member
    Messages: 14

    Sure will. I will need to borrow a buddys controller and I will clean up and re grease my connections. I usually use brakleen and compressed air to clean the pins side and brakleen and a brush for the female side. Any other recommendations on the cleaning process? Die electric is the grease I use.
    Kris
     
  8. Western1

    Western1 Senior Member
    from MI.
    Messages: 676

    I have also seen that symptom with a joystick and it was related to the joystick. When I hooked up a different one the condition was gone.
     
  9. Blackpearl#1

    Blackpearl#1 Junior Member
    Messages: 14

    Have not forgotten about this but its 75 degrees out and will hope to get the plow on the truck next week when it cools down a little. Again thanks to all that replied
    Kris
     
  10. Western1

    Western1 Senior Member
    from MI.
    Messages: 676

    Good luck! Don't wait too long!