1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New to western

Discussion in 'Western Plows Discussion' started by fireboy5722, Nov 4, 2014.

  1. fireboy5722

    fireboy5722 Senior Member
    Messages: 284

    New to western and installed everything on my truck myself, my question is with out the blade hooked up should I be able to turn power on on controller? My will not that's why I'm asking haven't picked up blade yet so was just checking to see if it would turn power on.
     
  2. seville009

    seville009 Senior Member
    from CNY
    Messages: 733

    No - have to have both plugs connected before anything will work.
     
  3. Gear_Head

    Gear_Head Senior Member
    from IL
    Messages: 245

    Power to the controller yes, even with blade off. Unless western has various trucks wire it differently.
     
  4. seville009

    seville009 Senior Member
    from CNY
    Messages: 733

    It won't with my 2007 Ultramount MVP; have to have both plugs connected before anything works. Tried it one time when i just wanted to move it and didn't connect the lights; had to connect the lights to get it to work.
     
  5. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,924

    Are you talking ultramount, or unimount?
     
  6. fireboy5722

    fireboy5722 Senior Member
    Messages: 284

    Ultramount 2
     
  7. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,924

    So fleet flex to boot. Yea plows gotta be hooked up.
     
  8. fireboy5722

    fireboy5722 Senior Member
    Messages: 284

    Thanks for the help picked blade up yesterday everything works great!
     
  9. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    With the multiplex system the controller lights up and can be turned on with only the light (11 pin plug) connected. You don't need the second plug connected but if you don't connect the second one the red light in the controller will flash indicating communication error when you do turn it on.