1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New problem with old plow

Discussion in 'Fisher Engineering Discussion' started by PaulT, Dec 31, 2009.

  1. PaulT

    PaulT Junior Member
    Messages: 19

    I have an old speedcast cable/hydraulic setup on my 90 Chevy.

    Put new O rings in the valve body a few weeks back and it's worked great for the 2 times I've plowed this year, but recently the plow has decided it doesn't want to go down.

    It's like it's on Viagra and it's been up for 4 hours, so I'm calling the professionals :D

    Cable adjustments are all good, I tried pushing the spool in manually and couldn't get it to go at all. Up isn't an issue at all, it's very smooth, as is angling.

    Any thoughts?
     
  2. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Loosen the hose on the lift cylinder and see if it drops....
     
  3. PaulT

    PaulT Junior Member
    Messages: 19

    With the truck off, when I pushed up on the control while checking that end of the cable, the plow did come right down.
    Going to feed the horses & then pull the valve out and see if I can see anything inside it that may be stopping the spool from moving in.
     
  4. PaulT

    PaulT Junior Member
    Messages: 19

    Ah ha! Took the spool out and found a little piece of some kind of plastic in one of the valleys on it.
    Removed, reassembled & she's working like a champ. Just in time for the weekend snow!

    Thanks for your input 2COR
     
  5. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

    Glad you got her working...