1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New plow Installed,Got a bad Squeak Help

Discussion in 'Commercial Snow Removal' started by Snow Encrusted, Dec 29, 2004.

  1. Snow Encrusted

    Snow Encrusted Member
    Messages: 66

    Had new plow installed now front end is Squeaking every time i hit a bump,also had add a leaf installed. PLEASE HELP!! :cry:
     
  2. alittle1

    alittle1 Member
    Messages: 35

    Get out the silicon and spray the front springs or lift the front end up to release tension on front leaf springs and put a dab of lithium grease on the spring ends. You may have to use a pinch bar to get between them. Or two miles down a washboard road will take the rust off the springs.
     
  3. Snow Encrusted

    Snow Encrusted Member
    Messages: 66

    Truck is new no rust I looked,cant see any worn spots It all looks good.Something is lose,Don't want to f-something up.
     
  4. alittle1

    alittle1 Member
    Messages: 35

    Bumper bolts or support arms! Go over the hardware and loosen off and then re-tighten bolts. Could be a mis-alignment.
     
  5. Snow Encrusted

    Snow Encrusted Member
    Messages: 66

    The bumper,I've been thinking about that,They took off air dam from bumper, maybe its lose,Will check tomorrow, its dark and cold here,right now.I could use some tips from members,so I Don't look like a fool when I bring it back. :help: :help: :help:
     
    Last edited: Dec 29, 2004
  6. Snow Encrusted

    Snow Encrusted Member
    Messages: 66

    Please HELP. :help: :eek: :angry:
     
  7. Frozen001

    Frozen001 Senior Member
    from Rome NY
    Messages: 908

    New Plow New Truck... hmmmm... take to back to the dealer who installed it tell them to find the problem and fix it. Don't worry about looking like a fool, it wasn't then before they put the plow on so they should fix the problem. and if they don't take it to you car dealer where you got the truck have them fix it and send the bill to the plow dealer.
     
  8. Snow Encrusted

    Snow Encrusted Member
    Messages: 66

    Spring shackle blots were rubbing on new plow frame.Problem solved.
     
  9. dlcs

    dlcs 2000 Club Member
    Messages: 2,149


    Glad to hear, you got it fixed.
     
  10. 04superduty

    04superduty PlowSite.com Addict
    Messages: 1,354

    were the bolts not tightened enough? there is at least a 1/2 inch between the front spring hanger bolts and the plow under carriage.