1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New hose and coupler issue

Discussion in 'Meyer / Diamond Products Discussion' started by nathan11507, Dec 17, 2011.

  1. nathan11507

    nathan11507 Member
    Messages: 68

    Okay i bought some new hoses and coupler for my meyers e-60 c-8 plow. The thing is the the male ends on the hose i bought have been apparantley updated cause there not the same as on the old ones. These are meyers replacement parts from napa. And the coupler i got wont go in my pump. The old coupler thats on it is threaded on the outdside and of course screws in to the pump the new on has no threads on the outside i hope this makes sense. And is there a way i can use the new ones with and adapter fitting?
     
  2. leolkfrm

    leolkfrm PlowSite.com Addict
    Messages: 1,436

    napa carries aftermarket parts not oem.....maybe someone them pkg wrong
     
  3. 95HDRam

    95HDRam Senior Member
    Messages: 157

    Not sure, I always get my hoses from a dealer when possible. Have you checked with Napa to see if you got the correct hose? If you did I would either look for the right hose elsewhere or see if any adapter is available.
     
  4. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,698

    You bought the wrong fitting. If you are talking about the connector that screws into the side of the PA block, it should have a male threaded end and male coupler end. Sounds like you bought the coupler that a hose would screw into(has threads on the inside of the coupler)