1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New Holland L185

Discussion in 'Truck & Equipment Repair' started by jcos, Nov 28, 2011.

  1. jcos

    jcos Junior Member
    Messages: 24

    New Holland L185 keeps blowing a fuse when I shift from low to high. Once I shift from low to high speed after about 2 minutes it blows the fuse in the engine compartment. Any help on where to start? Thanks
     
  2. 4wydnr

    4wydnr Senior Member
    from N. IL
    Messages: 151

    I have the same issue on my ls180, no one has answered my thread either.

    A friend of mine is a John Deere mechanic he said he would come check mine out. When he gets it fixed I'll try to post the results here for you.
     
  3. jcos

    jcos Junior Member
    Messages: 24

    I think it's fixed, talked with service guy at the dealer, he said probably the two speed solinoid, changed it today drove it around for a while and never died. We'll run it tomorrow for a while and see
     
  4. 4wydnr

    4wydnr Senior Member
    from N. IL
    Messages: 151

    That's what I'm suspecting. Please keep me updated.
     
  5. MGMatt

    MGMatt Junior Member
    Messages: 7

    Defiantly check the 2 speed solenoid. The resistance should be 7-10 ohms. If it is less then it will blow fuses. Also check the harness to see if it is rubbing against anything. Hope that helps.