1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

New batt & high-output alternator, new motor, dimming lights & truck died

Discussion in 'Truck & Equipment Repair' started by theplowmeister, Jan 8, 2010.

  1. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,552

    Did they put in a larger wire from alt to batterie? Belt slipping? I bet bad altanater.
     
  2. toykle

    toykle Junior Member
    Messages: 7

    Not sure if they upped the wire size. Definitely will check.
    Belt slipping is another good suggestion!
    I hope it's not the alternator!!
    That'd have me down for the better part of the day :(
    Didn't realize that I'd posted this an hour ago. I was too busy rewriting the post to see your reply!
    Definitely have to give myself a couple-hour sleep break
    Thanks!
     
  3. toykle

    toykle Junior Member
    Messages: 7

    Thanks theplowmaster!

    Think we've determined that a diode went out in the brand new alternator (this from the guy who built it for us). It is charging, but not at the rate it should.

    Since the snow has stopped for a few days and we were able to finish off the route without too many problems (just had to turn off whatever possible), he'll pull the alternator Monday, replace the diode, and reinstall with 2 guage wire. (He'd have done it today if we wanted, but Monday works far better for us.) The wire on there now appears to be 8 guage, possibly 6.

    Definitely going to triple check the belt.

    Your assistance is greatly appreciated!
     
  4. theplowmeister

    theplowmeister 2000 Club Member
    from MA
    Messages: 2,552

    Also check the belt tensioner (If its a spring tensioner) they can get soft.
    I replace my belt every 50K miles, never had a belt problem. I'd hate to be layd up for a storm because a $40 belt went bad.