1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

NEW and need help with saber lights

Discussion in 'Truck & Equipment Repair' started by wildplow, Dec 22, 2010.

  1. wildplow

    wildplow Member
    Messages: 31

    i recently decided to upgrade to the saber lights...i have it all hooked up but am having issues

    1st...When i turn on my truck head lights (switch to light moduels off) = both high and low beams are on in the truck, plus the high beam indacator is always on...

    And when the switch to the moduels is on the plow lights come on and the truck lights go off like i beleive are to do...but the plow lights have only one beam, not sure if its high beam or low, and again the high beam indacator is always on

    PLEASE HELP...SNOW IS COMING

    i want to add that this is on a 96 GMC 3/4 ton
     
    Last edited: Dec 22, 2010
  2. wildplow

    wildplow Member
    Messages: 31

    ill also add, the adapter harness i have on now is part# 07104 and the headlights are hb3 and hb4
     
  3. zzamud

    zzamud Member
    Messages: 49

    suuuure now i find this thread!!! im havn same issue on my chevy
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    You're 100% absolutely sure of that? Because it sounds like you have the incorrect adapters although I've seen these adapters incorrectly pinned or packaged many times.

    Look on the adapter connectors that plug into the trucks headlamps themselves, see if you can see a small "A" and "B" at each socket of the connector. What color wire is in socket A on each of the low and high beam connectors at the headlamps?
     
  5. wildplow

    wildplow Member
    Messages: 31

    i bought the hadapter harness from a truck equipment comp. so i figure the harness is right...however i will get to home from work early today and check out the wires/colors and position...but you know now a days people like to sell things as something there not....ie..sell aftermarket or homemade as oem

    the regular truck lights acted like this after i attached the adapter harness befor i even put power to the modules....

    i had a guy tryin to say it is both of my moduels, but i say no way, 1 they are brand new, 2 the plow lights still come on when i flip the switch

    im figuring the whole time its in the harness but need EXPERT help
     
    Last edited: Dec 23, 2010
  6. wildplow

    wildplow Member
    Messages: 31

    were did you get your harness? same year truck and all?
     
  7. zzamud

    zzamud Member
    Messages: 49

    harness off 2000 chevy and everything works but truck lights both hi and low on and only one light on plow dunno if its hi or low
     
  8. wildplow

    wildplow Member
    Messages: 31

    they are blue...i received an email with a pdf file that showed this exact harness and a detailed scamatic of it with color and letters, but when i compare the two(both pic and actuall part is 07104) the wires seem reversed on the one end of the adapter, the end that goes into the modules look right, but the other 4 ends the scamatic is showing them pinned backwards....what do you recommend i do? how hard is it to re pin it?
     
  9. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    I highly doubt you have the terminal extraction tool but a small piece of wire and some patience will also allow you to remove each pin and flip them over. The hack method is to chop all the plugs off and flip them over.

    Or simply exchange the adapters with a correct set.
     
  10. wildplow

    wildplow Member
    Messages: 31

    B&B you think that is my trouble? why would i get a messed up harness like that? and im not to careless, i will work at the plugs carfully if you think that switching them around is what needs to be done...i will not cut and splice...id rather spend the money IF NEED BE to get another....but if i can simply fix this one, id like too.....i guess some nutball had his head up his arse the day he built this harness...

    so B&B what do you think bud?
     
  11. zzamud

    zzamud Member
    Messages: 49

    I dont think mine are pinned backwards they workd on a 2000 truck same as mine. Mine just has autoheadlights and according to meyer i need a seperate adapter 07108. But local meyer dist. Says they just unhook the auto headlamps. Because i think somewhere its backeeding the his and lowbeams. I just cant figure out how to unhook the auto lamps. Guess im just tryi g to save the 130 for the adapter 07108
     
  12. wildplow

    wildplow Member
    Messages: 31

    i hear that zzamud.....
     
  13. zzamud

    zzamud Member
    Messages: 49

    Im going to meyer dealer on mon or tues. And they gonna fix. Whatever they do to fix i will pass the info along
     
  14. wildplow

    wildplow Member
    Messages: 31

    thank you very much....im thinkin my harness has to be messed up...some truck equip. company sent me the scamatic of the 07104 harness, i was told this is the right harness for the application, its just the scamatic dosnt match the harness i have in my hand exactly.....if all i have to do is match the scamatic it shouldnt be a hard fix....but then again i dont want to mess up the expensive modules...
     
  15. wildplow

    wildplow Member
    Messages: 31

    what do you think B&B
     
  16. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Absolutely. The blue (common) wires should all be in the "B" side of the sockets not the "A" which means they're pinned for a positive common system instead of the negative common system your truck is. If you have the schematics look at p/n 7185 and you find yours are pinned as a 7185 adapter... because those are the ones for a positive common system.

    So they were either assembled incorrectly or labeled incorrectly, which as I stated before both are pretty common. Meyer has never been highly regarded for their outstanding quality control.
     
  17. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Are they both the same body style?
     
  18. wildplow

    wildplow Member
    Messages: 31

    you are the man B&B....thanks a bunch...ill let ya know the out come...let me know what i owe ya and a paypal address for your time and ill shoot it right over to ya...merry christmas too
     
  19. wildplow

    wildplow Member
    Messages: 31

    wired up one side, man those pins are a pain....hooked it up and it worked perfect...
     
  20. zzamud

    zzamud Member
    Messages: 49

    It work out for u wildplow? So which socket are u switchn the b one?