1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Neutral creep on deere 6675

Discussion in 'Heavy Equipment' started by In2toys, Nov 9, 2009.

  1. In2toys

    In2toys Senior Member
    Messages: 319

    I have a John deere 6675 skidsteer that I keep having to adjust the neutral creep on it. It started acting up after plowing last weekend & I've adjusted it about 4 times since then. It stays normal for a couple of hours & then it's off to the races. I thought maybe one or both of the shocks on the levers were bad so I disconnected them & readjusted & the problem is still there. Any thoughts or ideas???
     
  2. Kenkreger

    Kenkreger Member
    Messages: 31

    Loose inthe linkages somewhere, putit up on blocks and play with the adjustments,look for loose conections/
    Ken
     
  3. In2toys

    In2toys Senior Member
    Messages: 319

    Thanks for the help guys. The bushing on the centering plate was way worn. I replaced that & the hub & Adjusted it AGAIN (up on blocks) & so far so good. I haven't had a chance to really work it yet, but it made it out of my shop, onto the trailer & parked at the grocery store I plow with out going out of whack again. So hopefully that takes care of it. I still think I may need some new shocks, but @ $51 a hit, they may have to wait till the next snow check comes in...
     
  4. In2toys

    In2toys Senior Member
    Messages: 319

    doh, THanks Ken, I thought this was a reply to this same questions posted on another site...