1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

need some suggestions

Discussion in 'SnowDogg Snow Plows' started by F150dash, Dec 23, 2011.

  1. F150dash

    F150dash Member
    Messages: 98

    I went to hook up my 75md today and it won't move. All I get is a clicking noise. The light is green on the remote. So that seems to be fine. Any ides or hints would be great. Thanks
  2. smoorman

    smoorman Sponsor
    Messages: 447

    I'm assuming the motor is not turning on, based on your description.

    Connect the two large terminals on the solenoid with a large screwdriver or wrench - see if the plow motor turns on (the plow will move left). If this works, it is likely the solenoid that is bad. If it doesn't work, you're not getting power at the motor, or the motor is bad (not that common).

    Put a test light at the motor terminals. If you're getting full voltage at the motor and it's not spinning - the motor may be bad.
    Put a test light at the grill connector (the two large sockets)
    Put a test light at the solenoid terminal

    DIRISHMAN PlowSite Veteran
    Messages: 4,249

    All I can say is WOW SCOTT !!!! Here it is after 11:00PM and your on this site seen whats up ..That is AWSOME.......and very welll respected which is why I am going to buy a New 8.5 vx with wings hopefuly soon if not deffinatley next year Being I have been out of work since 07 with an Injury
  4. F150dash

    F150dash Member
    Messages: 98

    Thanks for the advice, after a closer look at the wiring i noticed that a wire was completely rusted off, this would have been an easy fix had the large terminal had not broke. So i had to get another one of those but since my dealer is a couple hrs away i had to find a replacement part, it is all up and working but every now and then the light on the controller will blink red, single constant blink.