1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

"Need Some Help" plow will not angle left or right

Discussion in 'Western Plows Discussion' started by buckmaster66, Nov 23, 2008.

  1. buckmaster66

    buckmaster66 Junior Member
    Messages: 8

    I have a cable isarmatic mark llla plow. I just had to replace the the cable linkage enclosure for the left and right turn on the plow and also replaced that cable. I have up and down but no left or right now. I checked couplers on both hoses (working fine), i also ckecked both hydra turn ram couplers (working fine). Pump was just flushed, screen cleaned and there are no leaks. I did notice when i try to go left or right the pump trys to pull the plow up a little. Motor is running fine just can't get left or right to go. Need some help.
     
  2. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    3 way not adjusted correctly.
     
  3. buckmaster66

    buckmaster66 Junior Member
    Messages: 8

    so does that mean i have to keep adjusting the cable til i get it right? Or is the three way something different?
     
  4. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    You have to adjust the 3-way valve, there is no adjustment on the raise/lower cable. You have to get Up/Down working correctly before you can do anything with turn. You will also find that once youstart playing with the turn functions that you will have to "fine" tune up/down.

    If you havent already, go to westerns site and look under publications to find the mechanics guide for the cable operated isamarkIII.
     
  5. buckmaster66

    buckmaster66 Junior Member
    Messages: 8

    My up and down work properly. I just don't have left or right at all
     
  6. buckmaster66

    buckmaster66 Junior Member
    Messages: 8

    Got everything working properly now. "Thank you for your help crash935"