1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

need some help plow not lifting. meyer e47

Discussion in 'Meyer / Diamond Products Discussion' started by gixxer_grand, Jul 11, 2009.

  1. gixxer_grand

    gixxer_grand Junior Member
    Messages: 6

    i have an 88 toyota 4runner with a small older style blade, it has a e47 pump. this plow was originally on another vehicle just like this one and it worked fine, i switched it over to this vehicle and it worked fine but the truck was barely used for a year, now when i try to lift the blade or angle it doesnt do anything. I can hear the selenoid click but nothing else happens any idea what might be the problem?
     
  2. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

  3. gixxer_grand

    gixxer_grand Junior Member
    Messages: 6

    the motor was rebuilt 2 years ago and was used only for a year and not very much...if that helps...
     
  4. Chrisxl64

    Chrisxl64 Senior Member
    from CT
    Messages: 574

    Get out a tester and see if power is indeed reaching the motor for starters, if it isn't back track from there.

    If it is, then its most like a mechanical fault, cylinder could be seized, might be no fluid. Though with your angling cylinders I'm thinking its either a fault in the elctrical or some type of valving problem.
     
  5. gixxer_grand

    gixxer_grand Junior Member
    Messages: 6

    thanks guys i got to work for now i think it was just some bad connections somewhere im just going to go over all of them clean them up and put some electrical grease on them.
     
  6. bcofdayton

    bcofdayton Member
    Messages: 55

    My plow has nothing up or down right or left, one minute then works fine the next. I've double checked the fluid and it is full
     
  7. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Check/clean all of your power and control connections. What type plow?
     
  8. bcofdayton

    bcofdayton Member
    Messages: 55

    It's a Meyer
     
  9. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Check and clean ALL your connections. Make sure the grounds are good and that the 12 volt motor solenoid is securely mounted. What control, slick stick or dual controls?
     
  10. bcofdayton

    bcofdayton Member
    Messages: 55

    it's a dual
     
  11. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Make sure the wires are properly connected to the back of the plug
     
  12. R.J.S. SNOWPLOW

    R.J.S. SNOWPLOW Senior Member
    Messages: 892

    I had same problems it was the joy stick (slick stick)
     
  13. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    He doesn't have the slic stick he said he has the duals.
     
  14. action3457

    action3457 Junior Member
    Messages: 3

    i have a e47 meyers and my motor worked fine as can be last year now im wondering how i can test it with out the solenoid being hook up just the motor it self
     
  15. action3457

    action3457 Junior Member
    Messages: 3

    the motor on my plow is dead but worked fine last year help!!!!!!!!!!

    i bought meyer plow E47 last year went threw the whole unit new seals the works excpt the motor it work fine i mean killer now i bought new solenoid and hooked every thing up and the hot wire to the solenoid got smokin hot when i hit the switch to lif it up do i need a motor or is there some other problem help before the snow comes and where is a good cheap site::help::cry::(
     
  16. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,993

    Did it work before you put the new soleniod on?