1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

need more power

Discussion in 'Ford Trucks' started by danmc, Feb 11, 2004.

  1. danmc

    danmc Member
    Messages: 84

    Hey everyone,
    I have an 89 F250 with 5.7 V8, 110K miles. I noticed going up rather long hills it likes to take it's time. I have to get a long running start to keep up a reasonable speed. Case in point - the other day going up a particular hill I was passed by a tandem that was carrying a load in it's bed. Other than the usual tune up which I will give it when the weather gets warmer are there any other low budget things I can do?
    Thanks!
     
  2. The Boss

    The Boss 2000 Club Member
    Messages: 2,099

    Sounds to me like the motor is getting tired.:nod: :waving:
     
  3. Eyesell

    Eyesell 2000 Club Member
    Messages: 2,101

    as stupid as this sounds, and I'm sure you do this, I had a car that required the oil to be changed every two thousand miles because of power loss. As soon as I put fresh oil in it there was a noticeable difference. I mean on the expressway I could actually get up to 75 with fresh oil. I had 130,000 miles on it and this was 15 years ago. Now they have oil for high mileage vehicles, give it a try ;)
     
  4. oldmankent

    oldmankent PlowSite.com Addict
    Messages: 1,318

    maybe you need to do a fairly intensive tune up. You could have a fuel pump problem, or possibly a clogged fuel filter. Or maybe the catalytic converter if you have one is clogged up and restricting flow. You may want to take it to a place and have them do a full look over of the whole thing. By the way, did it have more power in the past?
     
  5. Plow Meister

    Plow Meister PlowSite.com Addict
    Messages: 1,174

    Oldmankent may be correct. Oil and filter are a must at 3000 miles. But don't overlook other filters in your truck. Fuel filters being the most ignored one. Give the cat a whack with a hammer. Do you hear anything rattle? It may be plugged? How is your air filter? Plugs and wires? How about the coil? At 110,000 miles, you shouldn't have any substancial power loss. You should be able to get at least 75,000 to 100,000 more miles out of it with proper maintenance.
     
  6. Mebes

    Mebes Senior Member
    Messages: 387

    I agree with this one it get's overlooked alot.
    A plugged up exhaust system will show up as a low vacuum reading with a sometimes wild needle.
    The other thing that I might add. Is your automatic transmission shifting properly? Sometimes kick down cables stretch out and need to be adjusted. This causes early up shifts (low rpms) and not downshifting soon enough while going up hills.
    Try putting it in 2 to force a downshift and see if you have more power in those big hills.
    Never mind this if you have a manual transmission.
    I have never seen a late oil change cause a lack of power as discussed above. But you never know.
     
  7. Mebes

    Mebes Senior Member
    Messages: 387

    One more thing on the 87 f350 I had there was a secondary fuel pump under the drivers door attached to the frame by the fuel filter (2 pumps 1 in tank 1 on frame) that would come disconnected from time to time. (Usually killing the truck) I don't know if your 88 is the same setup but might be worth a look to see if both pumps are running.
     
  8. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    Has this just started or taking a while to get this bad?
    The engine may of jumped timing due to a stretched chain. You check your timing? The ignition modules go bad all the time too, I have put 5 on one truck and 2 on another. Make sure the computer is advancing the timing after you plug the spout line back in. If the engines EFI it may have low fuel pressure due to a bad pressure regulator. The fuel pumps both have to be working. One is in the tank (low pressure) the other's on the drivers side frame rail ( high pressure). It's right under the front edge of the door inside the frame rail with a shroud around it. The fuel filter is forward of the high pressure pump, at least on my 89 it is. My 5.8's got almost 150k on it and it runs real strong with just a little oil smoke at startup. Check all connections under the hood, it has a bunch of ground lines all over the hood area.
    All else fails get the haynes single model manual and start checking out components. Pollution controls have effects on the engine's performance too.
     
  9. danmc

    danmc Member
    Messages: 84

    Thanks for the great input everyone!
    I bought the truck knowing it would need some work but I thought most of the problems were electrical (the previous owner had a ground running directly to the alternator). The truck has always been weak, I figured it was because the truck sat for a year before I bought it. I'll take it to the shop and have them look at the specific things posted in everyone's replies. Also, battery gauge doesn't work and fuel gauge for my front tank works but reads extreme full and extreme empty (when it reads empty I still have approx 6 gallons left) the rear tank always reads empty no matter what.....
    Thanks again - Dan
     
  10. Mebes

    Mebes Senior Member
    Messages: 387

    Hey Danmc any updates on that trip to the shop?
    To satisfy my curiosity.:confused: :confused: :confused:
     
  11. danmc

    danmc Member
    Messages: 84

    I'm goinh to take it over to the mechanic where I work - just have't had the time yet....I posted it for sale in the Used Truck forum though....