1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Need lighting help please!!!

Discussion in 'Fisher Engineering Discussion' started by padec21, Dec 19, 2009.

  1. padec21

    padec21 Member
    from ct
    Messages: 63

    I have a set of Meyer nite sabres on a late 90 early 2000 fisher mm1 set up. previous owner had it done or did himself.
    Anyway my passenger side hi-beam didnt work. both lows worked. driver side hi worked.
    I unwrapped his taped splicing and some of the connections were loose and came undone. crimp connectors.
    here is what I have
    Passsenger side
    Fisher side - Meyer side
    blk/orange - black
    purple - green
    black(low beam) - blue
    brown - yellow (this one I know is the parking lamps)
    white - unused fisher hibeam wire
    red - unused meyer wire
    white - unused meyer wire.
    I put the wires back togdether to match driver side.
    With the black and blue wire together I have both lights on. I think they are both hi-beams on. When I flash lever nothing happens. Lights appear very bright.
    I undid black and blue and put the blue with the fisher side white. Thats when I have both lows working but only driver side hi.

    Driver side
    Fisher side - Meyer - side
    grey - green
    brn - yellow
    black.orange - black
    black - blue
    white - unused fisher wire
    red - unused meyer wire
    white - unused meyer wire.

    this is the splice. They are both factory wires in the factory wire casings.

    Can anyone shed some light. I am all ready for big noreaster but may not have working lights.
    Please help!!!!
     
    Last edited: Dec 19, 2009