1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Need help with Sabers

Discussion in 'Meyer / Diamond Products Discussion' started by snowdays, Dec 12, 2009.

  1. snowdays

    snowdays Senior Member
    from Ohio
    Messages: 119

    I just installed a used plow setup on my '99 Superduty. The plow lights are not operating right. When I switch to the plow side, the highbeam indicator on the dash is on for both high and low and then when I switch to high beam, the plow lights go dim. Any ideas. I thought it might be the adapter plugs were incorrect but I have 2 sets from Fords that are identical.
     
  2. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    Are both sets of adapters you have identical? They could be adapters for HB1 Bulbs , not the HB5 that your Superduty has .

    Correct wiring for the HB5 (07102) adapters on the male plug ( the one that plugs into the headlight ) from left to right looking at the wire side (back) of the plug is :

    A- White

    B- Blue

    C- Red

    For the record the HB1 (07106) adapters are wired :

    A- Blue

    B- White

    C- Red

    Hope this helps

    TOM
     
    Last edited: Dec 12, 2009
  3. snowdays

    snowdays Senior Member
    from Ohio
    Messages: 119

    Thanks for the help! That was the problem, I had the wrong set of adapters and the colors you gave me helped identify that.
     
  4. Nasty-Z

    Nasty-Z Senior Member
    Messages: 370

    No problem , did you re-pin the conectors to solve the problen , it is easily done on the adapters .Just make sure you do the male and female ends :D

    TOM