1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Need help with Blizzard Plow light wiring.

Discussion in 'Truck & Equipment Repair' started by Stuiez, Nov 27, 2013.

  1. Stuiez

    Stuiez Junior Member
    Messages: 7

    Hi All,

    New guy here. Having an issue with my lights. Thanks in advance for your help.

    Its a Blizzard plow (7.5' I think) on a 2006 Chev 2500.

    When switched to plow lights I get:

    -Plow low beams and turn signals work, Truck headlights are off.
    -No marker lights, No high beams on plow lights. (Is this normal?)

    When switched to truck lights I get:

    -Plow lights off, Truck lights on as normal.
    -Drivers side high beam on as well and the high beam switch in the truck does nothing.

    I think the package was originally for a 88-98 GM truck. When I bought it, everything was on a Toyota Tacoma and it all worked fine. I bought the head light adapter harnesses and plugged everything in without cutting any wires. I've checked the relays and they seem to be good. Any info would be greatly appreciated.

    Thanks
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    What blizzard is it. Ph1 or dd blizzard?
     
  3. Stuiez

    Stuiez Junior Member
    Messages: 7

    Don't know. It's this one...

    [​IMG]

    [​IMG]

    [​IMG]
     
  4. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Ph1 or predd blizzard
     
  5. Stuiez

    Stuiez Junior Member
    Messages: 7

    It's a power hitch set up. I'm gonna guess its PH1. It's not PH2. I've looked online and I don't know what dd or predd is. Sorry.
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Dd= duglas dynamics,,western fisher owners
    Predd= before they were bought out. While different setup
    How many relays do u have?
     
  7. Stuiez

    Stuiez Junior Member
    Messages: 7

    2 per side. 4 total
     
  8. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Ok. First. Look at them all and make sure there nit corroded. Pull the relays out look at em etc..
     
  9. Stuiez

    Stuiez Junior Member
    Messages: 7

    All connections look good. The relays are new.
     
  10. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Ok. And there the relays that have the 87a pin correct. It should be 5 pins
     
  11. Stuiez

    Stuiez Junior Member
    Messages: 7

    Yes. 5 pins each
     
  12. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    Ok. Making sure you have the right relays.
    Gunna have to do so digging for the manual
    No maker lights on plow at all? The plow light switch dont matter. Try bulb? Test light it?
     
  13. Stuiez

    Stuiez Junior Member
    Messages: 7

    Right. Everything works when I supply direct power to test bulbs but not when hooked up normal.
     
  14. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,951

    from the manual
    verify the grn/ylw wire for gnd is connected
    verify the blk/wht wire for pwr is connected
    grey wire is your pking light, ck the connector at the truck(where you spliced into the factory harness) then that wire feeds the light relays via a blk/wht wire. from what the manual states