1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

need help diagnosing....

Discussion in 'Fisher Engineering Discussion' started by stillen, Nov 2, 2008.

  1. stillen

    stillen Senior Member
    Messages: 247

    have a small problem with my MM2 on my dodge 3/4 ton

    I have a 3 plug system, 1 is power, 1 is for lights, 1 is the control for the motor... on a four port iso

    Its the lights that I am having problem with...

    my drivers side headlight on truck is dim. I swapped bulbs and the problem stays on the drivers side. So it's not the bulb.

    I swapped plugs 3 and 4 on the iso side, and the drivers light stays dim, so that rules out the iso.

    Everything follows the wire it self, they call it the short plug in harness...... you think im on the right track? I think it is the wire, those connectors are finiky
     
  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Check your ground connection(s), clean all your plugs and coat them with electric grease. Sound like a bad connector plug. Good luck.
     
  3. Clapper&Company

    Clapper&Company PlowSite Veteran
    from NE OHIO
    Messages: 4,413

    I agree, Ground or bad plug.

    Most likey a bad ground
     
  4. stillen

    stillen Senior Member
    Messages: 247

    quick update....

    im working correctly now..


    installer (dealer) had wired my 3 prong harness wrong . He had the orange and blue wire reversed. This is the highbeam wire and the ground wire. It took me awhile to figure it out because the ground was geting it's path back from the low beam wire. I've seen this before, i cant believe i didnt think of it sooner. I had already invested in another short side harness for my truck when i noticed the colores were reversed. Whats worse is that the dealer i got it from does not take back any electrical part, so i'm stuck with it.... I might just ebay it..