1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

need help bad western isamatic mark iiia wireing from pump to joy stick

Discussion in 'Western Plows Discussion' started by bj cremers, Nov 2, 2012.

  1. bj cremers

    bj cremers Junior Member
    Messages: 5

    all wireing on pump is factory .....my western pump has six wires coming out of it ,,red,blk,white,yellow orange,green, and comming from controler i have 3 wires to power pump coils light blue, green,white, its a factory western joy stick that originaly came with pump was working in another truck i did not take it out any help would be great thx
     
  2. Chiputz

    Chiputz Senior Member
    Messages: 165

    Is the joystick powering up and not functioning, or what's happening? If you plugged it into an existing truck harness and it's not powering up check the fuse that is inline under the dash on the red wire coming out of the truckside of the 6 pin plug. Make sure the red wire has a 12 volt supply when the key is turned on.
     
  3. bj cremers

    bj cremers Junior Member
    Messages: 5

    yes its got power ...its not functioning proper coils ...wire colours dont match thats the problem im having 6 coil wires on pump ..3 out of joystick that send 12v when moving joystick functions ....each coil has 2 wires coming off them
     
  4. Chiputz

    Chiputz Senior Member
    Messages: 165

    Best advice I can give is go to western's website and look up the wiring schematics. They are color coded and vehicle specific. Did you check the plug at the grill for corrosion? That can cause malfunctions like that just like a bad ground can. Each coil has 2 wires because one is for the ground.
    Good Luck, should be something simple.
     
  5. bj cremers

    bj cremers Junior Member
    Messages: 5

    thx for your input conectors all good just not sure what wires go together westerns site is not showing the 6 pin pump harness diagram
     
  6. Chiputz

    Chiputz Senior Member
    Messages: 165

    Check out the harness install manual for your truck, the 6 pin wiring should be listed in there as well as the 9 or 12 pin connections at the grill plug. The Unimount service manual will tell you the electrical operation for each function as well as the color coding in the troubleshooting section.
     
  7. nealybird

    nealybird Senior Member
    Messages: 718

    I'm confused. this is a straight blade power unit, right? with three coils? the cover over the coils should have a decal that shows which wires go to the coils. it should be green, white, and blue and then the black one to all three coils. you didn't mention blue at all, so I'm puzzled.
    anymore info to go on? any white tag with part number on the harnesses?
     
  8. bj cremers

    bj cremers Junior Member
    Messages: 5

    thanks guys i got it all coils needed to be grounded to chasiss
     
  9. bj cremers

    bj cremers Junior Member
    Messages: 5

    i think someone got in to the coil cover before me colours dident jive once i gronded coils it worked the bottem tabs on coils are ground to cassiss and the top ones get trigger from blue green and white thx to all,,,,,,,,,,,,,,, should have knon better same on my myers but my myers coils are single wire and they ground throgh pump