1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Need help B&B and others.

Discussion in 'Truck & Equipment Repair' started by newhere, Jan 27, 2011.

  1. newhere

    newhere PlowSite.com Addict
    from Fenton
    Messages: 1,288

    hey guys i have a western unimount that has treated me rather good over the years.

    I was just using it and noticed a whine, thinking it was the truck i stepped out side and found out it was the western motor making the whine. The motor was running but the plow wasnt moving at all, every thing still works up down side to side but the motor stays running. It was pulling so much juice it melted the truck side plug a little and melted the insulation on one of the cables up by the motor.

    Do you guys have any advice on this one?

    Thanks in advance for the information.
     
  2. Mister Plow

    Mister Plow Senior Member
    Messages: 139

    Solenoid is stuck. Hit it with a hammer,
     
  3. newhere

    newhere PlowSite.com Addict
    from Fenton
    Messages: 1,288

    i will go check now. thanks
     
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    soleniod is sticking. more than likely a dirty or bad connection makes it stick. bad connection= low voltage=sticky solenoid.

    a hammer may do it. a quick check may also.
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Ditto on the solenoid assuming the controller isn't sticking. If you want a good solenoid that will last I recommend a Trombetta. Thumbs Up