1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Need help 99 tahoe light problems.

Discussion in 'Meyer / Diamond Products Discussion' started by rollnthunder, Dec 6, 2005.

  1. rollnthunder

    rollnthunder Junior Member
    Messages: 21

    My inlaw just got done putting a plow on his tahoe and he ordered the saber light kit and modules for it.He put it all in and did the test of taking the green wire and touching the positive post and the plow lights came on like they should.So he button the rest of it up and when you turn the key on the high beams are on and the indicator in the dash is on and you cant turn the high beams off.We have checked grounds and harness.If he turns the plow lights on they come on but you cant control the high low beam.Its like the harness is back feeding.He has a meyer plow with the saber light kits and wiring adapters.He has a 4 headlight system what im wondering is did someone sell him the wrong adapters or module.Thanks
  2. Killswitch

    Killswitch Senior Member
    Messages: 246

    That could be. My experience is theres no dealers or outlets that know any more about those lights and the wiring than you or I do.

    Cant help you but you seem on the case in the right direction.

    My sabres didnt start working properly till I mounted a set of KC Daylighter driving lights under them on the towers as additional and backup lights.

    I swear theyve worked perfect ever since that day.
  3. rollnthunder

    rollnthunder Junior Member
    Messages: 21

    I was reading in a plow parts book today and they mention negative and positive excite for the modules.Could it be he has the wrong modules and its back feeding.We unhooked the low beams from the module and hooked them back up to the stock harness and left the high beams still ran threw the modules and most of the lights will work like they will change over like they should.Except we are still getting a dim high beam light on in the dash cluster.And then when you plug the low beam lights back in to the module all 4 lights on the truck will stay on high beam and the high beam indicator is on and you can flip the low high switch all day and they wont change.Thanks for the help guys
  4. rollnthunder

    rollnthunder Junior Member
    Messages: 21

    I think i may have found the problem they keep telling him at CPW that he needs the 07108 kit and thats for seperate daytime running lights but his are ran threw the stock headlights and that calls for a 07104 kit....Thank god im in the autoparts business.This has been a 2 day deal what a waste of time.Now i know how customers feel when they come in to my murrays store and have gotten the wrong part from one of my parts guys.