1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

NEED HELP!!! 4wd not working

Discussion in 'Chevy Trucks' started by snyps, Jan 17, 2007.

  1. snyps

    snyps Senior Member
    Messages: 101

    Ok I have searched for this problem and seen many post about it on the older trucks so here it goes.

    I have an 2002 2500HD 8.1/ally LT with the push button 4wd.

    When I shift into 4 HI, I hear the T-case shift (Normal Sound) and the 4Hi light just blinks. Same thing for 4-low ( and I do put it in netural). Now I also can put the T-Case in Netural and the red light shows perfect.

    When I move the truck in 4hi the drive shaft does move due to the T-case engageing (I hope and not becasue the front axle actuator is engaging).

    I think it has to be the front axle actuator or the wireing to it? Do you agree?
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    snyps, if you want to be sure that it's in the axle actuator (or the wiring to it) put it in 4WD and leave the ignition on.Jack up one front corner of the truck and spin the tire that's off the ground while watching the front drive shaft,if the tire spin's and the drive shaft doesn't then your actuator isn't working.If the drive shaft does spin when you turn the tire then the T-case isn't engaging.
  3. Plow

    Plow Junior Member
    from home
    Messages: 2

    it's the push button switch

    and it needs to be replaced. It's a common problem which is quick and simple to fix.