1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

Myers plow wont go up and down

Discussion in 'Commercial Snow Removal' started by bfbchief, Dec 9, 2003.

  1. bfbchief

    bfbchief Junior Member
    from CT
    Messages: 19

    First storm of the year and of course something has to happen.

    I have a Myers plow (I am not sure what model the pump motor is) its an electric motor and its on a 1987 Dodge W250 (so it's an older motor)

    Problem is I have two spereate controls (one makes the plow go up and down, the other makes it go side to side) well when I use the control switch to try to make the plow go up it will not go up. BUT...if I push up on the switch that makes the plow go up and down and at the same time I hold the switch that makes the plow go left and right I can get the plow to go up.

    Does anyone have any idea what could be wrong? I am kind of a newbie to plowing and don't know alot about it.

    Thanks for any help and or ideas.
     
  2. slowpoke

    slowpoke Member
    Messages: 53

    When you hit the up switch alone does the motor run? I've got a copy of the old meyers electrical manual somewhere around here, I'll see if I can dig it out and see what they recommend for troubleshooting
     
  3. bfbchief

    bfbchief Junior Member
    from CT
    Messages: 19

    That is a good question...I am not sure and I don't have the truck with me (its at my brothers house right now). If the motor does not run when I go up with the switch what could be the cause of that?

    Also I have no problem putting the plow down. I just hit the down switch and it goes down without a problem and with out me having to use the angle switch like I do when I have to raise it.
     
  4. slowpoke

    slowpoke Member
    Messages: 53

    It sounds like a wiring problem to the power solenoid from your up switch. The meyers toggle switches are a mess of wires. The clue is that it will go UP when you press the up switch along with an angle. That indicates that the correct relay combination is operating.

    If the motor does not run when you switch up the problem is at the switch wiring with the common wire (not GROUND) that runs between the various switches to power the solenoid.

    It could also be (not highly likely) a diffective switch .

    Check out the motor when you can and see if it operates then repost the result or send me a pm or email
     
  5. slowpoke

    slowpoke Member
    Messages: 53

  6. bfbchief

    bfbchief Junior Member
    from CT
    Messages: 19

    Thanks for posting the manual...I do believe that is the motor.

    I did go over to my brothers house to try it again. When I pushed the switch to make the plow go up nothing (motor did not turn on) Plow goes down fine using the up and down switch. Motor works fine going left to right.

    Any other ideas?
     
  7. slowpoke

    slowpoke Member
    Messages: 53

    Use the trouble shooting guide. My guess is that it is in the switch wiring or the switch itself. The up valve works fine if you are able to have it go up when you activate the motor. You can check this out (requires two people) 1 to hold the switch in the up position the 2nd to short the power solinoid to activate the motor.

    Concentrate on the switch wiring in the trouble shooting guide
     
  8. maintenanceman

    maintenanceman Member
    Messages: 32

    I found my old wiring diagram for the two seperate switches for Meyers electro_touch units. Your problem should be in the white jumper wires located on the back of your raise lower switch. This wire should tie into the angle switch and run to the selonoid. Check to see if you have 12 volts at the back of the switch on the white wire when you raise the blade. Easiest method is to use a test light. If there is power at the switch the problem should be where this wire attatches to the angle switch. This should be your trouble, as I understand that you say that the blade will raise when operating the angle switch together with the raise switch. I will attatch my wiring diagram for you. If this one doesn't look like yours I do have another older diagram I can attatch. hope this helps.
     

    Attached Files:

  9. bfbchief

    bfbchief Junior Member
    from CT
    Messages: 19

    Thank you VERY much to the both of you. I will check out this white wire over the weekend. Will get back on what I find.

    Thanks again
    Josh