1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

My V-plow just quit on me

Discussion in 'Boss Plows Discussion' started by nbuzz, Jan 10, 2012.

  1. nbuzz

    nbuzz Junior Member
    Messages: 24

    I am a subcontractor, so It gets run fairly hard in AK. Went through the troubleshoot guide on the boss website, according to it I need to replace the pump motor. I want to make sure I am diagnosing correctly before I throw parts at it.

    Its a 8'2'' poly V, I was running last night and the headlights on the plow were dimming out very hard every time the plow motor would run, so I started watching the idiot gauge on the dash, and the plow was dropping me to 9-10 volts (according to the dash) it usaully never does that. I thought could be my alternator, had it spin tested and the batteries (both 850 cc batteries on my 12valve) load tested both right were they should be.

    the troubleshoot guide and the dealer both agree pump motor. I tested the soleniod and have voltage at the motor when all pressure functions are used. I pulled the motor and tried to jump it with some cables to see if it would run, nothing. ( I just hooked it to an extra deep cell batt. I have for the boat, positive to post and negative I would touch the body of the motor as its a single post motor).

    Is there anything else I can do to test? or does anyone have more insight on this issue?
  2. BOSS_JG

    BOSS_JG Senior Member
    Messages: 194

    If you put 12 volts directly to the motor and it didn’t run, we would recommend replacing the motor. Hope this helps. You can also reached our Technical Services department directly at 906.776.3500 to discuss if you wish.
  3. nbuzz

    nbuzz Junior Member
    Messages: 24

    thanks for the reply. I just got back from the dealer or stealer I should say ha, with a motor. should be on later this afternoon.
  4. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    Enjoy that 800.00 repair bill!
  5. nbuzz

    nbuzz Junior Member
    Messages: 24

    LOL, It wasn't that much!! I would wait a week to have one shipped for that much!! I only paid $291.00 but that is only for the motor itself, no gear pump or valve block. I could've waited and only paid $130.00 +shipping, but its supposed to snow Thursday and I want to be ready.

    Who is your Dealer? they should be :gunsfiring:
  6. Ultra Duty

    Ultra Duty Member
    from NE OHIO
    Messages: 65

    save your old one and you can get that rebuilt for 70-100.00 and have a good spare