1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

my first install

Discussion in 'Hiniker' started by eastender, Dec 6, 2011.

  1. eastender

    eastender Junior Member
    Messages: 15

    installed my hiniker 700 all steal plow on sunday, it was my first install , not to bad nice and neat all the wiring came out good it took the hole day with a buddy, anyway should i keep it hooked up for a few day to make sure its going to be fine for the snow any takes on how i should test every thing thanks...........
     
  2. Snowzilla

    Snowzilla Senior Member
    from Iowa
    Messages: 397

    Congrats. I was slower at my set up. If you've done everything by the manual. The truck headlights work in truck mode, the plow lights work in plow mode. Parking lights, turn signals work, etc. Test up/down, left/right. Controller goes from float to normal mode I'd say you're good.
     
  3. topdj

    topdj Senior Member
    Messages: 396

    Coat all electrical connections with dielectric grease to prevent corrosion, I did this to all connections.
     
  4. eastender

    eastender Junior Member
    Messages: 15

    grease

    yeah i used grease through out the hole install , now i am just waiting for the snow?