1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

MVP ultra mount plow shuts off sometimes.

Discussion in 'Western Plows Discussion' started by aspenplow, Dec 17, 2012.

  1. aspenplow

    aspenplow Member
    Messages: 41

    So I have had this issue for awhile where my plow will just stop responding to my round pin pistol joystick. I would remedy this by getting out unplugging all the wires adding dieelectric grease and then plugging them back in. Today this issue is reoccurring every 5 minutes or less, and unplugging it is only working a handful of the time. I also noticed the solenoid clicks and sometimes the buttons on the controller appear to be different (I.e. up is vee, left moves blade right), so I cleaned the grease from the connectors using brake cleaner and it worked great for another 5 minutes and now nothing seems to get it to raise! Anyone have any thoughts or suggestions... Thx in advance
     
  2. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,947

    Well let's here. What kinda plow,,,uni or ultra mounts ?? Yr of tk ? A preliminary,,,sounds groundish related.
     
  3. mishnick

    mishnick 2000 Club Member
    Messages: 2,243

    Sounds to me like that plug you are removing, greasing and reconnecting is probably failing. The pins or sockets may be corroded or the wires going into the plug may be breaking.
     
  4. aspenplow

    aspenplow Member
    Messages: 41

    That was exactly the problem. Not where th cord failed, but when I ran a jumper worked fine. Ordered new cable and works great now! Thx for the help! :drinkup: