1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

mvp pump wont quit running

Discussion in 'Western Plows Discussion' started by becpropertymain, Oct 14, 2010.

  1. becpropertymain

    becpropertymain Member
    Messages: 43

    hey guys need alittle help here just got my new 9.6 mvp (thanks Jim) the install went just fine filled it full of fluid and was going to start to bleed out the air so as soon as i plug the power in to the plow the pump starts running. what gives can anyone steer me in the right direction thanks for the help guys
     
  2. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    Sounds like the solenoid is stuck,allowing constant juice to the motor,could also be a faulty controll.

    Or....
    If you did all the wiring yourself,you may have hooked 12 volts to the same side of the solenoid.
     
  3. becpropertymain

    becpropertymain Member
    Messages: 43

    i will check the head gear it was already put together i just had t wire the truck side, run the hydro lines and put the blade together :mechanic:
     
  4. no lead

    no lead PlowSite.com Addict
    Messages: 1,308

    the solenoid is on the plow if it is brand new. it may be stuck on. grab a test light and check to see if it is indeed stuck. check the small terminals on the solenoid. one is ground, the other is activate. you can disconnect the power wire at the motor until you figure it out.
     
  5. becpropertymain

    becpropertymain Member
    Messages: 43

    ill give it a shot thanks
     
  6. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    I had the exact same issue with my MVP late last year. If you turn to the trouble shooting section of your users manual you'll see a section that addresses this problem. It says that you should check the solenoid which is what my problem was. I slipped in a new one and I was good to go.
     
  7. becpropertymain

    becpropertymain Member
    Messages: 43

    well guys i just got the new solenoid and no good the pump still runs and it doesn't matter if the controler is pluged in or not and yes i made sure it was wired correctly now what please help my local dealer is no help to me at all
     
  8. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    Plow controll module out on the pump.
     
  9. becpropertymain

    becpropertymain Member
    Messages: 43

    well looks like i will be calling jim at esi because the local dealer wants me to pay for the parts untill they get rembersed from western :mad:
     
  10. becpropertymain

    becpropertymain Member
    Messages: 43

    okay so i put the new module on and great the pump doesnt run anymore but the controller wont turn on now what im starting to think i should have just bought it from a local company then this would all be there problem
     
  11. becpropertymain

    becpropertymain Member
    Messages: 43

    anybody?????????
     
  12. fabcraftinc

    fabcraftinc Member
    Messages: 69

    There are 4-- 4 amp mini fuses on the plow side harness. There is also a 7.5 amp fuse on your truck side harness. Check all of these fuses. It is possible you went directly to ground when you made your module and solenoid switch.
     
  13. becpropertymain

    becpropertymain Member
    Messages: 43

    all fuses are good
     
  14. LON

    LON Senior Member
    Messages: 749

    Is your local dealer in Prospect?
     
  15. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    Check the fuse you tapped for 12v switched power,it may have back fed and blown that,otherwise it may have just blown the pc board in the controll,check for 12v at your square plug in the cab first
     
  16. becpropertymain

    becpropertymain Member
    Messages: 43

    so still no working plow i just put a new harness in the truck and it still does not work the controller will not turn on now what im at about my wits end i never should have switched from boss!!
     
  17. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    You need to verify your 12v switched power IS STILL GOOD,didn't blow a fuse and your not hooked on the dead side,after that check with a known good controll,not sure how far into PA you are,i'm 45 min across to NY,if your up for the drive i'll fix ya.
     
  18. becpropertymain

    becpropertymain Member
    Messages: 43

    I grab power off of the same wire i have that my salter control hooked to it is a fused line straight from the battery and the salter works so i know i have power there and nobody around me that owns a vee plow so i cant borrow someone elses controler
     
  19. becpropertymain

    becpropertymain Member
    Messages: 43

    and i am 20 minutes north of pittsburgh
     
  20. Arc Burn

    Arc Burn PlowSite.com Addict
    Messages: 1,138

    With the plow hooked up,unhook your controll and check for power at the #1 pin,it will be the red wire by itself(the other red will have another wraped around it)
    Also check the #4(all black,nothing around it) for ground
    If these check out,it's your controll,otherwise your going back thru the harness